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INTRODUGAO:

O morango (Fragaria x ananassa) € um fruto consumido mundialmente e o Brasil & o 17° maior produtor segundo
dados recentes de 2020 (“FAOSTAT”, [s.d.]). Possui grande valor nutricional, sendo rico em vitaminas e minerais (XIE;
LIU; GUO, 2021). No entanto, sua textura pouco firme traz fragilidade em relagdo a danos mecéanicos e seu grau de
umidade promove alta atividade microbiana, fatores que tornam o morango uma fruta de rapida deterioragdo (OLIVEIRA
et al.,, 2021; YOON et al., 2020).

A avaliagdo da maturidade é usualmente realizada por métodos destrutivos, tal como a medicao dos Sélidos
Soluveis Totais (SST) em um fruto, responsaveis pelo sabor adocicado a partir da presenca de agUcares, vitaminas e sais
minerais. Quanto mais maduro o fruto, maior o nivel de SST presente em sua composicdo (KWAK et al., 2021; PAVARIN,
2020).

O presente trabalho teve o objetivo de encontrar o grau de maturidade de um fruto através do uso de uma técnica
Optica ndo destrutiva chamada de Biospeckle Laser (BSL) (BRAGA JUNIOR; RIVERA; MOREIRA, 2016). O modo como
o feixe de um laser se comporta ao refletir de uma superficie € chamado de speckle e, em uma amostra com atividade
biologica € chamado de speckle dinamico (FRACAROLLI, 2011, 2014). A partir da captura de uma sequéncia de imagens
desse granulado (Time History Speckle Pattern, THSP) é possivel realizar o processamento dos dados utilizando
algoritmos de intensidade de pixels nas imagens e gerar um mapa de atividade do fruto. Esse é o método grafico das
Diferencas Generalizadas (GD) (ARIZAGA; TRIVI; RABAL, 1999; BRAGA JUNIOR; RIVERA; MOREIRA, 2016; BRAGA
etal.,, 2011; PAVARIN, 2020)

O processamento também pode ser feito a partir dos métodos numéricos do Momento de Inércia (Ml) e
Average Value of Difference (AVD. MI apresenta dois valores de saida, IM1 e IM2. IM1 representa a normalizacdo da
matriz de co-ocorréncia (COM) de Cardoso e Braga (2014), enquanto o IM2 representa a normalizacédo de Arizaga,; Trivi;
Rabal (1999). A normalizacéo é feita seguindo a equacéo 1. A equagéo 2 retorna uma medida de propagagéo dos valores
de M ao redor da diagonal principal da matriz, que € um momento de segunda ordem e sua intensidade indica o nivel de
atividade da amostra, baseado na variacdo da intensidade dos pixels da imagem. O AVD utiliza o valor absoluto ao invés
do quadrado, diminuindo as ampliagdes no calculo do Momento de Inércia. Apresenta quatro saidas, AVD1, AVD2, AVD3
e AVDA4. As trés primeiras sdo normaliza¢Bes propostas por Cardoso e Braga (2014) enquanto AVD4 é uma normalizacéo
proposta por Arizaga; Trivi; Rabal (1999). A equacao 3 apresenta o calculo de AVD1, o valor padrdo de saida do programa.
O célculo de AVD?2 é feito da mesma maneira que o IM1 (Equacéo 2) e o calculo de AVD3 segue a equacgao 4 (BRAGA
JUNIOR; RIVERA; MOREIRA, 2016; PAVARIN, 2020).

Nij

Mij = NG Equagéo 1
MI = Yij Mij(i — j)* Equagéo 2
AVD1 = Y ij {Mijli — j|} Equagéo 3
AVD3 = Y ij Mij(i — j)? — AVD1? Equacéo 4

Com o avanco da tecnologia, o uso de modelos de visdo computacional tridimensional para colocar em
perspectiva resultados esta se tornando mais comum (CHEN et al., 2020; SAMPAIO; SILVA; MARENGONI, 2021;
SANTOS et al., 2017). Para esse trabalho foi feita a reconstrugdo 3D do morango com aplicacdo da textura encontrada
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com o BSL. O mapa de atividade gerado com o método GD foi utilizado como textura para verificar a viabilidade do modelo
tridimensional.

METODOLOGIA:

Foram utilizadas 20 amostras da variedade Sweet Charlie obtidas em supermercado, sendo 10 no estagio
maduro e 10 verdes. Primeiramente, foi realizada a gravagéo do video com o laser dos 20 morangos, seguida da captura
do modelo tridimensional dos 10 morangos maduros e finalizando com a medi¢éo dos sélidos sollveis de todas as
amostras previamente identificadas.

Para o Biospeckle foi utilizado um pano preto opaco para evitar a reflexdo da luz e cobrir a superficie em que o
morango estava apoiado, a camera de um smartphone modelo iPhone 11, com captura HD de 1080 pixels a 60 quadros
por segundo, uma lente convergente com foco de 35 mm, um filtro polarizador para diminuir a intensidade do laser e uma
caneta Laser Pointer verde com 532 nm de comprimento de onda (Figura 1.1). Em amblente completamente escuro, foi
feita a captura durante 10 segundos a cada 180° de
rotacdo do fruto. A posicdo vertical do fruto
possibilitou a melhor captura das imagens para o0s
morangos. O software Free Video to JPG Converter
v. 5.0.92 quebrou o video em 228 quadros, com
descarte dos 100 primeiros. Os 128 quadros
remanescentes passaram por um filtro 8-hit,
transformando as imagens de RGB para escala de
cinza, necessaria para o processamento do BSL, a
partir do software ImageJ. Por fim, o pacote BSLTL
(BRAGA JUNIOR; RIVERA; MOREIRA, 2016) do
Octave® foi utilizado para obter o valor do Average Figura 1.1. Montagem dos equipamentos para o experimento em local
Value of Difference e Momento de Inércia como completamente escuro. Fonte: autor.
métodos numéricos, além do método das
Diferencas Generalizadas como método grafico (ANSARI; NIRALA, 2013; BRAGA JUNIOR; RIVERA; MOREIRA, 2016;
PAVARIN, 2020).

A captacao das imagens para a reconstrucao do 3D foi feita utilizando o sensor Microsoft Kinect 360, com auxilio
do software ReconstructMe (HEINDL et al., 2015). O fruto foi colocado em uma superficie plana e elevada, de modo que
foi possivel realizar uma revolugdo em volta do morango, tentando obter o maximo de pontos possiveis. O programa
gerou um arquivo .ply que foi exportado para o MeshLab 2016 para realizar a reconstrucao tridimensional (PAVARIN,
2020; YANG; FRACAROLLLI, [s.d.]).

Para iniciar a reconstrucgéo foi feita a elimina¢éo de pontos indesejados gerados na imagem inicial (Figura 2.1)
utilizando os comandos Select Vertexes > Delete the current set of select vertexes. A reconstrugéo pelo método de Poisson
requer a computacdo da normal, que foi realizada seguindo o caminho Filters > Normals, Curvature and Orientation >
Compute normals for point set. O nimero de vizinhos que possibilitaram a reconstrugédo foi 20 (Figura 2.2). O método de
Poisson foi feito a partir dos comandos Filters> Remeshing, Simplification and Reconstruction > Screened Poisson Surface
Reconstruction. A base do morango ficou aberta, sendo necessario corta-la entre as repeticées do Poisson utilizando os
mesmos comandos da eliminagéo dos pontos desnecessarios, até que o resultado fosse satisfatério, com cerca de 80000
vértices (Figura 2.3). Por fim, para anexar a textura do BSL seguiu-se inicialmente com os comandos Filters > Normals,
Curvature and Orientation > Normalize Face Normals e Filters > Normals, Curvature and Orientation > Normalize Vertex
Normals, seguido de File > Import Raster. A textura foi fixada sobre 0 3D a partir de ajustes com imagens a cada 180° de
rotagdo (Figura 2.4). (PAVARIN, 2020; YANG; FRACAROLLI, [s.d.]).

Figura 2.1 Figura 2.2 Figura 2.3 Figura 2.4

Figura 2.1. Resultado inicial da captagdo das imagens. Figura 2.2. Fruto apds limpeza dos pontos e normalizagdo. Figura 2.3.
Morango apds reconstrugdo pelo método de Poisson. Figura 2.4. Reconstrugdo final com emprego da textura obtida através
do BSL. Fonte: autor.

Por fim, os morangos foram triturados para realizar a medicdo dos Sdlidos Sollveis Totais utilizando um
refratdmetro portatil da marca ATAGO, modelo ATC-1. O experimento consistiu em pingar uma gota da polpa do fruto no
equipamento e observar a medida (ALARFAJ et al., 2021; BARIKLOO; AHMADI, 2018; DE SOUZA et al., 2014; DONG et
al., 2020; PINELI et al., 2011; SAMEC et al., 2016; VIDRIH et al., 2013). Os resultados foram expressos em °Brix (Tabela
1).
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RESULTADOS E DISCUSSAO:

Os 10 morangos maduros e os 10 morangos verdes foram numerados
conforme a Figura 3.1 e a Figura 3.2. A Tabela 1 apresenta os valores encontrados ‘
para os s6lidos solUveis das 20 amostras. “ . @

Tabela 1 - Medi¢éo de Solidos Soluveis Totais ‘ ‘ ¥ ‘
Maduros Verdes L LT o
Amostra °Brix Amostra °Brix PR P s
1 7,9 11 6,1 II}i;L;uch' 3.1. Morangos verdes utilizados
2 11 12 5'9 nos experimentos. Fonte: autor.
3 7,1 13 6,5
4 9,6 14 6,1
5 12,6 15 54
6 9,9 16 5,8
7 7,1 17 5,7
8 6,9 18 51
9 10,7 19 5,8
10 8,8 20 5,7
Média 9,16 Média 5,81 Figura 3.2. Morangos maduros
Desvio Padréo 0,611410028 | Desvio Padréo | 0,122429118 Zgii;:dos nos experimentos. Fonte:

Tabela 1. Medigdo de sdlidos soluveis, resultados expressos em 2Brix. Fonte: autor.

Os valores médios encontrados para os morangos maduros e verdes estdo de acordo com a literatura. (ALl et
al., [s.d.]; CAO et al., 2015; GABRIEL et al., 2019; KURCHAIDT PEREIRA CAMARGO et al., 2009; NUNES et al., 2006;
POZO-INSFRAN et al., 2006)

Nas Figuras 4.1 e 4.2 estéo os resultados das imagens obtidas através do Biospeckle Laser pelo método GD. O
mapa de atividade apresentou melhor visualizagdo para 0s morangos verdes em compara¢do com 0s maduros.

étodo GD para 10 morangos

Figura 4.1. Resultado do método GD para 10 morangos Figura 4.2. Resultado do m
maduros. Fonte: autor. verdes. Fonte: autor
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Ja o resultado da reconstrugéo tridimensional dos 10 morangos maduros pode ser observado na Figura 5. A
reconstrucéo foi bem-sucedida, assim como a aplica¢do da textura referente as Figuras 4.1 e 4.2. O programa utilizado
foi capaz de captar grande parte dos pontos com precisdo, o que facilitou a reconstrucao pelo MeshLab. Por fim temos
os resultados dos métodos numéricos AVD e MI, que podem ser observados
nas Tabelas 2 e 3. Como baixas varia¢des de intensidade de pixels adicionam

Tabela 2 - Medigdo do Average Value of Difference (AVD) e Inertia Moment (IM) - Amostras maduras
Morango Amostra [IM1 M2 AVD1 AVD2 AVD3 AVD4
1 1/9,1816 1,69E+04 0,89816 9,1816 8,3749 1188,1
1 27,8567 6757,2 0,87419 7,8576 7,0943 631,53
2 1/6,6836 1,43E+04 0,7618 6,6836 6,1033 1121
2 2(11,359 2,81E+04 0,94757 11,359 10,462 1577,1
3 1]9,5532 1,33E+04 0,87329 9,5532 8,7906 893,29
3 2/4,3888 4765,5 0,63477 4,3888 3,9862 519,89
4 1|6,2492 9026,1 0,75975 6,2492 5,6719 710,33
4 2(2,5143 1,10E+04 0,42753 2,5143 2,3315 762,7
5 111,339 1,02E+04 1,1813 11,339 9,9432 959,21
5 2(6,7132 3,49E+04 0,6157 6,7132 6,3341 1282,6
6 1/5,4917 2,22E+04 0,60729 5,4917 5,1228 1169,2
6 2(3,9332 8673,2 0,5648 3,9332 3,6142 799,78
7 1/4,2271 8409,6 0,58209 4,2271 3,8883 672,1
7 2|3,7814 7954,3 0,52464 3,7814 3,5062 599,24
8 1]3,1139 42275 0,52805 3,1139 2,835 439,34
8 22,2357 7684,7 0,41402 2,2357 2,0643 678,51
9 1|5,2634 1,18E+04 0,6062 5,2634 4,8959 794,65
9 22,5558 6843,7 0,40449 2,5558 2,3922 497,63
10 12,7383 8426,1 0,50111 2,7383 2,4872 638,46
10 27,2486 1,16E+04 0,76449 7,2486 6,6642 854,33
Média 5,821385 1,23E+04 0,673562 5,82E+00 5,328115 8,39E+02
Varidncia 8,33 61391206,78 0,04 8,33 6,76 87787,44
Figura 5. Reconstrucdo tridimensional das Desvio padrao 2,88610751| 7835,254098| 0,204464781| 2,886140919| 2,600212314| 296,2894576
amostras de morango. Fonte: autor. % desvp da media 49,5776779 6,35E+01| 30,35574766 4,96E+01| 48,80173033 3,53E+01
Erro 0,64535326| 1752,016078| 0,045719715| 0,645360729| 0,581425149| 66,25233681

baixos valores ao MI (Equagdo 2), os
morangos maduros devem apresentar

Tabela 2. Valores de AVD e IM para morangos maduros. Fonte: autor.

valores superiores em comparagéo com as Tabela 3 - Medigdo do Average Value of Difference (AVD) e Inertia Moment (IM) - Amostras verdes
amostras verdes (PAVAR|N, 2020). A Morango |Amostra [IM1 M2 AVD1 AVD2 AVD3 AVD4
discussdo é equivalente para o AVD. Para 11 1/5,9221 3481,2 1,1165 5,9221 4,6755 410,2
a normalizagdo IM2 e AVD4 observamos 12 1|4,8068 2696,2 0,89339 4,3068 4,0086 317,17
valores médios de 4870 e 4208229, 13 1|4,0697 3385,1 0,68713 4,0697 3,5976 380,7
respectivamente, para morangos verdes. 14 1|2,5145 4495 0,525 2,5145 2,2388 366,09
Enquanto isso, os valores aumentam para 15 1)3,7621 3258,4 0,88169 3,7621 2,9847 360,72
12300 e 839 nas amostras maduras. Dessa 16 1/14,828 1,16E+04 1,34 14,828 13,032 856,02
forma. os resultados foram satisfatorios 17 1/8,6945 1,12E+04  |0,95033 8,6945 7,7914 776,5

’ ; L 18 1/1,9549 12784 0,58216 1,9549 1,616 139,02
para 0 bservar diferenciagdo no grau de 19 1/0,92977 321,93 0,35285 0,92977 0,80527 59,189
maturidade ‘?'05 frutos a partir dos 20 1/9,659 7023,1 1,0824 9,659 8,4874 542,62
resultados obtldos_ com o BSL. L Média 5,714137 4,87E+03 0,841145 5,714137 4,923727 420,8229

Para projetos futuros € indicada a Varidncia 18,02] 14971198,39 0,09 18,02 1424] 6222265

testagem com lasers de diferentes cores € [ pegyio padrao | 4,244576204| 3869,263287| 0,303378931| 4,244576204|  3,77412972| 249444687
comprimentos de onda para observas O |9 desvp damedia | 74,28201676|  7,94E+01] 36,06737613| 74,28201676| 76,65188829| 59,27545458
comportamento do speckle dinamico. Além Erro 0,949116093| 865,1935733| 0,067837591| 0,949116093| 0,843921061| 55,77752767

disso, a utilizagdo de cameras sem lente
podem auxiliar na captagdo das imagens
para os métodos graficos.
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